PAT A1108 Finding Average (20分)甲级题解

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路:

1.判断是否有字母 有就是不合法字符
2.判断是否至多只存在一个'.',若超过一个以上就是不合法数字
3.判断是否在[-1000,1000]以内
4.判断若有小数点的数,是否小数点后最多只有两位
以上一起判断后如果不合符就是非法数字 符合则累计即可 很简单

代码实现:

#include <iostream>
#include <cstring>
using namespace std;

bool judge(string s) {
	for(int i=0; i<s.length(); i++) {
		if(isalpha(s[i])) return false;
	}
	if(s.find(".")!=string::npos) {
		s.erase(s.find("."),1);
		if(s.find(".")!=string::npos) return false;//多余一个.的情况
	}
	return true;
}

int main() {
	int n,cnt=0;
	cin>>n;
	double ans=0;
	string x;
	while(n--) {
		cin>>x;
		bool tag=true;
		if(x.find(".")!=string::npos) {
			int pos=x.find(".");
			if(x.length()-pos-1>2) tag=false;
		}
		if(!tag||!judge(x)||stod(x)>1000||stod(x)<-1000) {
			printf("ERROR: %s is not a legal number\n",x.c_str());
		} else {
			ans+=stod(x);
			cnt++;
		}
	}
	if(cnt>1) printf("The average of %d numbers is %.2f\n",cnt,ans/cnt);
	else if(cnt==1) printf("The average of 1 number is %.2f",ans);
	else printf("The average of 0 numbers is Undefined");
	return 0;
}
posted @ 2021-01-25 23:00  coderJ_ONE  阅读(176)  评论(0编辑  收藏  举报