HDU2087剪花布条
Problem Description
一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?
Input
输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。
Output
输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。
Sample Input
abcde a3
aaaaaa aa
#
Sample Output
0
3
代码:
- #include <iostream>
- #include <stdio.h>
- #include <cstring>
- using namespace std;
- int main()
- {
- char st1[1001],st2[1001];
- int i,j,k,t;
- while(scanf("%s",st1)!=EOF)
- {
- getchar();//接收回车字符
- t=0;
- if(st1[0]==35) break;
- scanf("%s",st2);
- for(i=0;i<strlen(st1);)
- {
- k=0;
- if(st1[i]==st2[0])
- {
- for(j=0;j<strlen(st2);j++)
- {
- if(st1[i++]==st2[j]) k++;
- else break;
- }
- if(k==strlen(st2))
- t++;
- }
- else i++;
- }
- cout<<t<<endl;
- }
- }