POJ 3254 Corn Fields[状压dp]

Corn Fields

Time Limit: 2000MS
Memory Limit: 65536K

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:

1 2 3
  4 


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:

有一个由01组成的场地,0代表不能放牧,1代表可以放牧。要求每个牛不和其他的牛相邻,求有多少种安排方式。

思路:

把每一行通过二进制换成一个数字,表示这一位的状态,要想不相邻,每一行的数和上一行的数按位与应该为零。然后存的时候要把初始状态的01互换,这样例如把(1101)存成(0010),这样当状态(1001)和(0101)和初始状态按位与才为零。

#include "stdio.h"
#include "string.h"
#include "algorithm"
using namespace std;
const int mod = 100000000;
const int maxn = 1<<13;
int dp[13][maxn];
int sti[13], sta[maxn];
int main(int argc, char const *argv[])
{
    int N, M;
    scanf("%d%d", &N, &M);
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < M; j++) {
            int a;scanf("%d", &a);
            if (!a) sti[i] += (1<<j);
        }
    }
    int cnt = 0;
    //筛去不符合左右不相邻的情况。
    for (int i = 0; i < (1<<M); i++) {
        if (!(i&(i<<1))) sta[cnt++] = i;
    }
    for (int i = 0; i < cnt; i++) {
        if (!(sti[0]&sta[i])) dp[0][i] = 1;
    }
    for (int i = 1; i < N; i++) {
        for (int j = 0; j < cnt; j++) {
            if (sti[i]&sta[j]) continue;
            for (int k = 0; k < cnt; k++) {
                if ((sti[i-1]&sta[k]) or (sta[j]&sta[k])) continue;
                dp[i][j] += dp[i-1][k];
            }
        }
    }
    int ans = 0;
    for (int i = 0; i < cnt; i++) 
        ans = (ans + dp[N-1][i])%mod;
    printf("%d\n", ans);
    return 0;
}
posted @ 2017-08-17 09:38  zprhhs  阅读(151)  评论(0编辑  收藏  举报
Power by awescnb