POJ 3061 Subsequence 【尺取法】

 

Subsequence

 

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
1
0 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

 

尺取法的思想是反复推进区间的开头和结尾,来求出满足区间的最小距离。


#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int S, n, ar[100000 + 10];
void solved() {
    int ans = n*2;
    int sum = 0, t = 0, s = 0;
    while (true) {
        while (sum < S && t < n) {
            sum += ar[t++];
        }
        if (sum < S) break;
        ans = min(ans, t - s);
        sum -= ar[s++];
    }
    if (ans == n*2) printf("0\n");
    else  printf("%d\n", ans);
}
int main() {
    int t;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &S);
        for (int i = 0; i < n; i++) {
            scanf("%d", &ar[i]);
        }
        solved();
    }
    return 0;
}

 



 

posted @ 2016-08-18 16:23  zprhhs  阅读(167)  评论(0编辑  收藏  举报
Power by awescnb