Processing math: 100%
2016-08-24 11:40 阅读 137 评论 0 推荐

POJ 2253 Frogger 【Floyd】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 37902   Accepted: 12199

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

copy
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

copy
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source


 

这个不是让求最短距离,而是两个之间所有路径中每个路径长度最大的最小值,用Floyd进行变形就可以解决。

又及:poj G++是过不了的(C++才可以)

复制代码
copy
#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
#define space " "
using namespace std;
//typedef long long LL;
typedef __int64 Int;
typedef pair<int,int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double Pi = acos(-1.0);
const int MOD = 1e9 + 7;
const int MAXN = 200 + 10;
double dist[MAXN][MAXN];
struct node{
    double x, y;
} a[MAXN];
double dis(node a, node b) {
    return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}
int main() {
    int cnt = 0, n;
    while (scanf("%d", &n), n) {
        for (int i = 0; i < n; i++) {
            scanf("%lf%lf", &a[i].x, &a[i].y);
        }
        for (int i = 0; i < n; i++) {
            for (int j = i + 1; j < n; j++) {
                dist[i][j] = dist[j][i] = dis(a[i], a[j]);
            }
        }
        for (int k = 0; k < n; k++) {
            for (int i = 0; i < n - 1; i++) {
                for (int j = i + 1; j < n; j++) {
                    if (dist[i][j] > dist[i][k] && dist[i][j] > dist[j][k]) {
                        dist[i][j] = dist[j][i] = max(dist[i][k], dist[j][k]);
                    }
                }
            }
        }
        printf("Scenario #%d\n", ++cnt);
        printf("Frog Distance = %.3lf\n\n", dist[0][1]);
    }
    return 0;
}
复制代码

 



 

本文作者: zprhhs

本文链接:https://www.cnblogs.com/cniwoq/p/6770802.html

版权声明:本作品采用知识共享署名-非商业性使用-禁止演绎 2.5 中国大陆许可协议进行许可。

posted @   zprhhs  阅读(137)  评论(0编辑  收藏  举报
编辑推荐:
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
· 现代计算机视觉入门之:什么是图片特征编码
阅读排行:
· 手把手教你在本地部署DeepSeek R1,搭建web-ui ,建议收藏!
· Spring AI + Ollama 实现 deepseek-r1 的API服务和调用
· 数据库服务器 SQL Server 版本升级公告
· C#/.NET/.NET Core技术前沿周刊 | 第 23 期(2025年1.20-1.26)
· 程序员常用高效实用工具推荐,办公效率提升利器!
Power by awescnb
点击右上角即可分享
微信分享提示
进入亮色模式
进入亮色模式