POJ - 3041 Asteroids 【二分图匹配】

 

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20881    

 

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

 

x和y进行匹配,好吧  没有看出来

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
//#define LOACL
#define space " "
using namespace std;
//typedef long long LL;
//typedef __int64 Int;
typedef pair<int, int> PAI;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double PI = acos(-1.0);
const int MOD = 1e9 + 7;
const int MAXN = 500 + 10;
int match[MAXN], n, m, ans;
bool data[MAXN][MAXN], vis[MAXN];
void init() {
    ans = 0;
    memset(data, 0, sizeof(data));
}
bool find_path(int x) {
    for(int i = 1;i <= n; i++) {
        if(!vis[i] && data[x][i]) {
            vis[i] = true;
            if(!match[i] || find_path(match[i])) {
                match[i] = x;
                return true;
            }
        }
    }
    return false;
}
int main() {
    int x, y;
    while (scanf("%d%d", &n, &m) != EOF) {
        init();
        for (int i = 0; i < m; i++) {
            scanf("%d%d", &x, &y);
            data[x][y] = true;
        }
        for (int i = 1; i <= n; i++) {
            memset(vis, false, sizeof(vis));
            if (find_path(i)) ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}

 



 

posted @ 2016-10-26 18:55  zprhhs  阅读(124)  评论(0编辑  收藏  举报
Power by awescnb