HDU 4405 Aeroplane chess (概率dp)


Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2219    Accepted Submission(s): 1441

Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 
Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 
Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 
Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 
Sample Output
1.1667 2.3441
 
Source
 
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4405

题目大意:在一条有n个格点的线上掷骰子,有1-6六个值,假设当前为止超过n,则胜利,有m个跳跃点。到x位置能够直接飞到y位置(x < y),问从起点開始到终点掷骰子的期望数

题目分析:设dp[i]为到第i个点还要掷的期望数,则显然
dp[i] = 0(i >= n)
dp[n - 1] = dp[n] * 1 / 6 + 1
dp[n - 2] = dp[n - 1] * 1 / 6 + 1
。。。
一直推到dp[0],注意两跳跃点的期望值直接相等就可以

#include <cstdio>
#include <cstring>
int const MAXN = 100005;
int const MAXM = 1005;
double dp[MAXN];
int turn[MAXN];

int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m) != EOF && (n + m))
    {
        memset(dp, 0, sizeof(dp));
        memset(turn, -1, sizeof(turn));
        for(int i = 0; i < m; i++)
        {
            int x, y;
            scanf("%d %d", &x, &y);
            turn[x] = y;
        }
        dp[n] = 0.0;
        for(int i = n - 1; i >= 0; i--)
        {
            if(turn[i] != -1)
                dp[i] = dp[turn[i]];
            else
            {
                for(int j = 1; j <= 6; j++)
                {
                    if(i + j >= n)
                        break;
                    dp[i] += 1.0 / 6.0 * dp[i + j];
                }
                dp[i] += 1.0;
            }
        }
        printf("%.4f\n", dp[0]);
    }
}




posted @ 2017-06-23 08:12  clnchanpin  阅读(157)  评论(0编辑  收藏  举报