hd acm1008
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2
3 2 3 1 0
Sample Output
17
41
Sample Way
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n,i,sum,floor[100]={0};
while(scanf("%d",&n)==1&&n!=0)
{
sum=0;
for(i=1;i<=n;i++)
{
scanf("%d",&floor[i]);
}
for(i=1;i<=n;i++)
{
if(floor[i]>floor[i-1]) sum+=(floor[i]-floor[i-1])*6;
if(floor[i]<floor[i-1]) sum+=(floor[i-1]-floor[i])*4;
}
printf("%d\n",sum+n*5);
}
return 0;
}
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】凌霞软件回馈社区,博客园 & 1Panel & Halo 联合会员上线
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】博客园社区专享云产品让利特惠,阿里云新客6.5折上折
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步