HDU 1686 Oulipo (KMP——统计模式串出现次数)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7384    Accepted Submission(s): 2965


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

 

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
 

 

Sample Output
1
3
0
 

 

Source
 
KMP模板题,返回模式串T在主串中出现的次数
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=1000000+5;
char S[MAXN],T[MAXN];
int nex[MAXN];
int slen,tlen;

void KMP_nex()
{
    int j,k;
    j=0;k=-1,nex[0]=-1;
    while(j<tlen)
    {
        if(k==-1 || T[j]==T[k])
            nex[++j]=++k;
        else k=nex[k];
    }
}


int KMP_count()
{
    int ans=0;
    int i,j=0;
    if(slen==1 && tlen==1)
    {
        if(S[0]==T[0]) return 1;
        else return 0;
    }

    KMP_nex();
    for(int i=0;i<slen;i++)
    {
        while(j>0 && S[i]!=T[j])
            j=nex[j];
        if(S[i]==T[j]) j++;
        if(j==tlen)
        {
            ans++;
            j=nex[j];
        }
    }
    return ans;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int kase;
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%s %s",T,S);
        tlen=strlen(T);
        slen=strlen(S);
        printf("%d\n",KMP_count());
    }
    return 0;
}
View Code

 

posted @ 2015-08-08 16:08  Cliff Chen  阅读(199)  评论(0编辑  收藏  举报