2015 Multi-University Training Contest 5 1002

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 276    Accepted Submission(s): 203


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn
 

 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai1m+z) mod l
1m,z,l5105,n=5105
 

 

Output
For every test.print the answer.
 

 

Sample Input
2
3 5 5 7
6 8 8 9
 

 

Sample Output
14
16
 

 

Source
 
题意:给出n,m,z,l得到Ai的递推式,求所有Ai+Aj的异或值
分析:所有异或的话(Ai+Aj)和(Aj+Ai)会抵消,最后是对所有的2*Ai(1<= i <=n)进行异或
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
int main()
{
    int n,m,z,l,kase;
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%d %d %d %d",&n,&m,&z,&l);
        LL num=0,ans=0;
        for(int i=2;i<=n;i++)
        {
            num=(num*m+z)%l;
            ans=ans^2*num;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2015-08-04 22:13  Cliff Chen  阅读(110)  评论(0编辑  收藏  举报