2015 Multi-University Training Contest 3 1004

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 596    Accepted Submission(s): 278


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

 

Output
Output an integer as described in the problem description.
 

 

Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR
 

 

Sample Output
3
6
 

 

Source
 
题意:一个人刷墙,刷墙的方向有'/'和'\'两种斜的刷墙方式,有红色和蓝色两种颜料,每个格子只能刷一次,而且要刷连续的一段,红色和蓝色都刷了就是绿色,给定墙的最终状态,问最少要刷几次才能到达最终状态
分析:模拟,到每个格子的时候往四个45°方向去扫描,绿色可以当做红色和蓝色两种颜色
 
题目的大坑就是只告诉你行数但是没有告诉你列数,所以列数和行数不一定相等,我呵呵呵呵
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
using namespace std;
const int MAXN=50+5;
char a[MAXN][MAXN];
int kase,n,m;

int main()
{
    //freopen("in.txt","r",stdin);
    scanf("%d",&kase);
    while(kase--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%s",a[i]+1);
        m=strlen(a[1]+1);

        int ans=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(a[i][j]=='R')
                {
                    ans++;
                    int x=i,y=j;
                    while(1<=x && x<=n && 1<=y && y<=m)
                    {
                        if(a[x][y]=='R') a[x][y]='.';
                        else if(a[x][y]=='G') a[x][y]='B';
                        else break;
                        x++,y++;
                    }
                }

                else if(a[i][j]=='B')
                {
                    ans++;
                    int x=i,y=j;
                    while(1<=x && x<=n && 1<=y && y<=m)
                    {
                        if(a[x][y]=='B') a[x][y]='.';
                        else if(a[x][y]=='G') a[x][y]='R';
                        else break;
                        x++,y--;
                    }
                }

                else if(a[i][j]=='G')
                {
                    ans+=2;
                    int x=i,y=j;
                    int xx=i,yy=j;
                    while(1<=x && x<=n && 1<=y && y<=m)
                    {
                        if(a[x][y]=='R') a[x][y]='.';
                        else if(a[x][y]=='G') a[x][y]='B';
                        else break;
                        x++,y++;
                    }
                    while(1<=xx && xx<=n && 1<=yy && yy<=m)
                    {
                        if(a[xx][yy]=='B') a[xx][yy]='.';
                        else if(a[xx][yy]=='G') a[xx][yy]='R';
                        else break;
                        xx++,yy--;
                    }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2015-07-29 10:57  Cliff Chen  阅读(164)  评论(0编辑  收藏  举报