POJ 1141 Brackets Sequence(区间DP)

 
Brackets Sequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25861   Accepted: 7281   Special Judge

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

Source

 

d[i][j]表示从下标i到下标j最少需要加多少括号才能成为合法序列。0<=i<=j<len (len为输入序列的长度)。

v[i][j]为输入序列从下标i到下标j的断开位置,如果没有断开则为-1。

当i==j时,d[i][j]为1

当s[i]=='(' && s[j]==')' 或者 s[i]=='[' && s[j]==']'时,d[i][j]=d[i+1][j-1]

否则d[i][j]=min{d[i][k]+d[k+1][j],d[i][j]} i<=k<j ,v[i][j]记录断开的位置k

 

输出结果时采用递归方式输出print(0, len-1)

输出函数定义为print(int i, int j),表示输出从下标i到下标j的合法序列

当i>j时,直接返回,不需要输出

当i==j时,d[i][j]为1,至少要加一个括号,如果s[i]为'(' 或者')',输出"()",否则输出"[]"

当i<j时,如果c[i][j]>=0,说明从i到j断开了,则递归调用print(i, c[i][j]);和print(c[i][j]+1, j);

              如果c[i][j]<0,说明没有断开,如果s[i]=='(' 则输出'('、 print(i+1, j-1); 和")"

                                                                     否则输出"[" print(i+1, j-1);和"]"

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int MAXN=100+5;
const int INF=0x3f3f3f3f;
char s[MAXN];
int dp[MAXN][MAXN],v[MAXN][MAXN],len;
void solve()
{
    for(int i=0;i<len;i++) dp[i][i]=1;
    for(int i=1;i<len;i++)
    {
        for(int k=0;k+i<len;k++)
        {
            int p=k+i;
            dp[k][p]=INF;
            if( (s[k]=='('&&s[p]==')') || (s[k]=='['&&s[p]==']') )
            {
                dp[k][p]=dp[k+1][p-1];
                v[k][p]=-1;
            }
            for(int j=k;j<p;j++)
            {
                if(dp[k][j]+dp[j+1][p]<dp[k][p])
                {
                    dp[k][p]=dp[k][j]+dp[j+1][p];
                    v[k][p]=j;
                }
            }
        }
    }
    return ;
}

void print(int star,int en)
{
    if(star>en)
        return ;
    else if(star==en)
    {
        if(s[star]=='(' || s[star]==')') printf("()");
        if(s[star]=='[' || s[star]==']') printf("[]");
        return ;
    }
    else if(v[star][en]==-1)
    {
        printf("%c",s[star]);
        print(star+1,en-1);
        printf("%c",s[en]);
    }
    else
    {
        print(star,v[star][en]);
        print(v[star][en]+1,en);
    }
    return ;
}
int main()
{
    memset(dp,0,sizeof(dp));
    memset(v,0,sizeof(v));
    memset(s,0,sizeof(s));
    scanf("%s",s);
    len=strlen(s);
    solve();
    print(0,len-1);
    printf("\n");
    return 0;
}
View Code

 

posted @ 2014-10-28 22:54  Cliff Chen  阅读(147)  评论(0编辑  收藏  举报