PAT(A) 1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A
#include <cstdio>
#include <algorithm>
using namespace std;

struct Student{
    int id;         //六位整数
    int grade[4];   //四门课的分数(A, C, M, E)
}stu[2010];
char course[4]={'A', 'C', 'M', 'E'};    //按优先级顺序存放,方便输出
int Rank[10000000][4]={0};              //全部初始化为0,便于后面的判断
//Rank[id][0]~Rank[id][3]为平均成绩及三门课成绩对应的排名

int now;    //划重点(1): cmp()中使用
//表示当前按grade[now], 即course[now]对应科目的分数来排序stu[]

bool cmp(Student a, Student b){
    //stu[]按now号分数递减排序(a在前)
    return a.grade[now] > b.grade[now];
}

int main()
{
    int n, m;
    scanf("%d%d", &n, &m);

    //步骤(1): 读入各科分数,其中grade[0]~grade[3]分别代表ACME (A:平均分)
    for(int i=0; i<n; i++){
        scanf("%d%d%d%d", &stu[i].id, &stu[i].grade[1], &stu[i].grade[2], &stu[i].grade[3]);
        stu[i].grade[0]=( stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3] )/3; 
    }
    //步骤(2): 枚举ACME中的一种,对所有学生按该分数从大到小排序
    for(now=0; now<4; now++){       //枚举ACME中的一种
        sort(stu, stu+n, cmp);      //对所有学生按该分数从大到小排序
        Rank[stu[0].id][now]=1;     //排序完,将now类科目分数最高的学生stu[0].id的排名Rank设为1
        for(int i=1; i<n; i++){     //对剩下的学生设置排名
            if(stu[i].grade[now]==stu[i-1].grade[now])  //与前一位学生该科分数相同
                Rank[stu[i].id][now]=Rank[stu[i-1].id][now];    //则排名也相同
            else
                Rank[stu[i].id][now]=i+1;
        }
    }
    //步骤(3): 查询并输出
    int query;      //查询的学生的id
    for(int i=0; i<m; i++) {
        scanf("%d", &query);
        if(Rank[query][0]==0)   //若未存入query号学生的平均成绩,即该学生id不存在
            printf("N/A\n");    //输出N/A
        else{
            int k=0;    //K用来选出 Rank[query][0~3]中最小的
            //Rank值越小,排名越高(作用类似 int min=MAXD)
            for(int j=0; j<4; j++){
                if(Rank[query][j] < Rank[query][k])
                    k=j;
            }
            printf("%d %c\n", Rank[query][k], course[k]);
        }
    }
    return 0;
}

 

posted @ 2017-03-14 16:59  claremz  阅读(215)  评论(0编辑  收藏  举报