PTA 5-10 Saving James Bond-Easy (25) - 图 - DFS

题目:http://pta.patest.cn/pta/test/16/exam/4/question/672

PTA - Data Structures and Algorithms (English) - 5-10

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12
Sample Output 1:
Yes
Sample Input 2:
4 13
-12 12
12 12
-12 -12
12 -12
Sample Output 2:
No
 

解法转自:http://blog.csdn.net/u013167299/article/details/42267129

#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
//#define lson rt<<1,l,MID
//#define rson rt<<1|1,MID+1,r
//#define lson root<<1
//#define rson root<<1|1
//#define MID ((l+r)>>1)
typedef long long ll;
typedef pair<int,int> P;
const int maxn=105;
const int base=1000;
const int inf=999999;
const double eps=1e-5;

struct node
{
    double x,y;   //坐标的X,Y
    int num;      //坐标的标号 便于标记(就像map的key)
} p[maxn];        //自定义图的节点 存储图

bool vis[maxn];   //访问标记
double d,n;       //鳄鱼数量,可跳跃的最大距离

int first_dis=1;      //第一次是在中心半径为15的岛上,所以特殊处理
//中心岛/鳄鱼->鳄鱼的距离
double dis(double x,double y,double xx,double yy)
{
    if(first_dis)
    {
        return d+15-sqrt((x-xx)*(x-xx)+(y-yy)*(y-yy));
        first_dis=0;
    }
    else return d-sqrt((x-xx)*(x-xx)+(y-yy)*(y-yy));
}

int first_pan=1;      //第一次是在中心半径为15的岛上,所以特殊处理
//判断是否可以到岸上
bool pan(node s)
{
    if(fisrt_pan)
    {
        first_pan=0;
        if(fabs(s.x-50)<=d+15 || fabs(s.x+50)<=d+15 || fabs(s.y-50)<=d+15 || (s.y+50)<=d+15)
            return true;
    }
    else if(fabs(s.x-50)<=d || fabs(s.x+50)<=d || fabs(s.y-50)<=d || (s.y+50)<=d)
        return true;
    return false;
}

//深度优先
int dfs(node s)
{
    if(pan(s))
    {
        return 1;
    }
    if(!vis[s.num])
    {
        vis[s.num]=true;
        for(int i=1; i<=n; i++)
        {
            if(!vis[p[i].num] && dis(p[i].x,p[i].y,s.x,s.y)>=0)
            {
                if(dfs(p[i])==1)
                    return 1;
            }
        }
    }
    return 0;
}

int main()
{
    cin >> n >> d;
    for(int i=1; i<=n; i++)
    {
        cin >> p[i].x >> p[i].y;
        p[i].num=i;
    }
    node s;
    s.x=s.y=s.num=0;  //初始位置(0,0),num标记为0
    if(dfs(s))
        puts("Yes");
    else
        puts("No");
    return 0;
}
posted @ 2015-09-30 17:08  claremz  阅读(207)  评论(0编辑  收藏  举报