【CJOJ P1365】最短路
http://oj.changjun.com.cn/problem/detail/pid/1365
Description
给出N个点,M条无向边的简单图,问所有点对之间的最短路。
Input
第1行两个正整数N,M(N<=100,M<=5000)
下面M行,每行3个正整数x, y, w,为一条连接顶点x与y的边权值为w。(x<=n,y<=n,w<=1000)
Output
包括N行,每行N个数,第i行第j个数为点i到点j的最短路,第i行第i个数应为0,数字之间空格隔开。
Sample Input
5 10
3 2 1
2 4 7
5 3 4
4 1 2
5 1 8
3 4 10
5 4 9
2 5 2
1 2 1
3 1 10
Sample Output
0 1 2 2 3
1 0 1 3 2
2 1 0 4 3
2 3 4 0 5
3 2 3 5 0
题解
让我们来温习一下弗洛伊德Floyd吧!标准裸题。不解释了。直接上代码
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<cstdio>
using namespace std;
void Floyd()
{
int n,m;
int g[101][101];
cin>>n>>m;
int a,b,c;
for(int i=1;i<=n;++i)
for(int j=1;j<=n;++j)
if(i==j)g[i][j]=0;
else
g[i][j]=99999999;
for(int i=1;i<=m;++i)
{
cin>>a>>b>>c;
g[a][b]=g[b][a]=c;
}
for(int k=1;k<=n;++k)
for(int i=1;i<=n;++i)
for(int j=1;j<=n;++j)
{
if(g[i][j]>g[i][k]+g[k][j])g[i][j]=g[i][k]+g[k][j];
}
for(int i=1;i<=n;++i)
{
for(int j=1;j<=n;++j)
cout<<g[i][j]<<' ';cout<<endl;
}
}
int main()
{
Floyd();
return 0;
}