cjweffort

博客园 首页 联系 订阅 管理

http://ac.jobdu.com/problem.php?cid=1040&pid=20

题目描述:

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

输入:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入:
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
样例输出:
13.333
31.500
// 题目21:FatMouse.cpp: 主项目文件。

#include "stdafx.h"
#include <cstdio>
#include <algorithm>
using namespace std;

const int N=1003;
typedef struct Node
{
	int javaBeans,catFood;
}Node;
Node node[N];

bool cmp(Node m1,Node m2)
{
	return m1.javaBeans*m2.catFood>m1.catFood*m2.javaBeans;
}

int main()
{
    int whole,m;
	while(scanf("%d%d",&whole,&m)!=EOF)
	{
		if(whole==-1&&m==-1)
			break;
		for(int i=0;i<m;i++)
			scanf("%d%d",&node[i].javaBeans,&node[i].catFood);
		sort(node,node+m,cmp);
		int getFood=0;
		int j=0;
		for(;j<m;j++)
		{
			if(whole<node[j].catFood)
				break;
			else
			{
				whole-=node[j].catFood;
				getFood+=node[j].javaBeans;
			}
		}
		double res;
		if(j==0)
		{
			res=1.0*whole/node[0].catFood*node[0].javaBeans;
		}
		else if(j==m)
		{
			res=1.0*getFood;
		}
		else
		{
			res=1.0*whole/node[j].catFood*node[j].javaBeans;
			res+=getFood;
		}
		printf("%.3lf\n",res);
	}
    return 0;
}


posted on 2013-03-05 11:12  cjweffort  阅读(136)  评论(0编辑  收藏  举报