cjweffort

博客园 首页 联系 订阅 管理

http://ac.jobdu.com/problem.php?cid=1040&pid=33

题目描述:

有一棵树,输出某一深度的所有节点,有则输出这些节点,无则输出EMPTY。该树是完全二叉树。

输入:

输入有多组数据。
每组输入一个n(1<=n<=1000),然后将树中的这n个节点依次输入,再输入一个d代表深度。

输出:

输出该树中第d层得所有节点,节点间用空格隔开,最后一个节点后没有空格。

样例输入:
4
1 2 3 4
2
样例输出:
2 3
// 题目34:树查找.cpp: 主项目文件。

#include "stdafx.h"
#include <iostream>
#include <math.h>
using namespace std;

const int N=1003;
int a[N];

int main()
{
    int n;
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
			cin>>a[i];
		int depth;
		cin>>depth;
		int start=(int)pow(2.0,depth-1);
		bool flag=true;
		for(int i=0;i<start&&start+i-1<n;i++)
		{
			if(flag)
			{
				flag=false;
				cout<<a[start+i-1];
			}
			else
				cout<<" "<<a[start+i-1];
		}
		cout<<endl;
	}
    return 0;
}


posted on 2013-03-05 11:28  cjweffort  阅读(171)  评论(0编辑  收藏  举报