cjweffort

博客园 首页 联系 订阅 管理
http://ac.jobdu.com/problem.php?cid=1040&pid=3
题目描述:
    Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
输入:

    测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (N<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有N行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。

输出:
    对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
样例输入:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
样例输出:
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
// 题目4:EXCEL排序.cpp: 主项目文件。

//#include "stdafx.h"
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
using namespace std;

const int N=100001;
typedef struct STU
{
	int no,score;
	char name[9];
}STU;
STU stu[N];

bool cmp1(STU m1,STU m2)
{
	return m1.no<m2.no;
}

bool cmp2(STU m1,STU m2)
{
	if(strcmp(m1.name,m2.name)!=0)
		return strcmp(m1.name,m2.name)<0;
	else
		return m1.no<m2.no;
}

bool cmp3(STU m1,STU m2)
{
	if(m1.score!=m2.score)
		return m1.score<m2.score;
	else
		return m1.no<m2.no;
}

int main()
{
    //freopen("F:\\test.txt","r",stdin);
    //freopen("F:\\output.txt","w",stdout);
	int n,m;
	int caseCnt=1;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0)
			break;
		printf("Case %d:\n",caseCnt++);
		for(int i=0;i<n;i++)
			scanf("%d%s%d",&stu[i].no,stu[i].name,&stu[i].score);
		if(m==1)
			sort(stu,stu+n,cmp1);
		else if(m==2)
			sort(stu,stu+n,cmp2);
		else
			sort(stu,stu+n,cmp3);
		for(int i=0;i<n;i++)
			printf("%06d %s %d\n",stu[i].no,stu[i].name,stu[i].score);
	}
    return 0;
}


posted on 2013-03-02 11:12  cjweffort  阅读(205)  评论(0编辑  收藏  举报