cjweffort

博客园 首页 联系 订阅 管理

http://ac.jobdu.com/problem.php?cid=1040&pid=6

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

// 题目7:Day of Week.cpp: 主项目文件。

#include "stdafx.h"
#include <cstdio>
#include <iostream>
#include <map>
#include <string>
using namespace std;

int mDay[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int mYear[2]={365,366};
map<string,int> cmap;
map<int,string> cmapAns;

void swap(int &a,int &b)
{
	int tmp=a;
	a=b;
	b=tmp;
}

int isLeap(int year)
{
	return (year%4==0&&year%100!=0||year%400==0)?1:0;
}

int days(int yy,int mm,int dd)
{
	int res=0;
	for(int i=1;i<mm;i++)
		res+=mDay[i];
	int tag=isLeap(yy);
	if(mm<=2)
		return res+dd;
	else
	{
		if(tag)
			return res+1+dd;
		else
			return res+dd;
	}
}

int dateDifference(int year1,int month1,int day1,int year2,int month2,int day2)
{
	bool flag=false;
	if(year2<year1||(year2==year1&&month2<month1)||
		(year2==year1&&month2==month1&&day2<day1))
	{
		flag=true;
		swap(year1,year2);
		swap(month1,month2);
		swap(day1,day2);
	}
	int firstDays=days(year1,month1,day1);
	int secondDays=days(year2,month2,day2);
	int res=0;
	for(int i=year1;i<year2;i++)
		res+=mYear[isLeap(i)];
	res=res+secondDays-firstDays;
	if(flag)
		return -res;
	else
		return res;
}

int main()
{
	freopen("F:\\test.txt","r",stdin);
	freopen("F:\\output.txt","w",stdout);
	cmap["January"]=1;cmap["February"]=2;cmap["March"]=3;
	cmap["April"]=4;cmap["May"]=5;cmap["June"]=6;
	cmap["July"]=7;cmap["August"]=8;cmap["September"]=9;
	cmap["October"]=10;cmap["November"]=11;cmap["December"]=12;
	cmapAns[1]="Monday";cmapAns[2]="Tuesday";cmapAns[3]="Wednesday";
	cmapAns[4]="Thursday";
	cmapAns[5]="Friday";cmapAns[6]="Saturday";cmapAns[7]="Sunday";
    int yy,mm,dd;
	string str;
	while(cin>>dd>>str>>yy)
	{
		mm=cmap[str];
		int res=dateDifference(2013,2,3,yy,mm,dd);
		if(res>0)
		{
			if(res%7==0)
				cout<<"Sunday"<<endl;
			else
				cout<<cmapAns[res%7]<<endl;
		}
		else
		{
			res=-res;
			cout<<cmapAns[7-(res%7)]<<endl;
		}
	}
    return 0;
}


posted on 2013-03-02 11:22  cjweffort  阅读(168)  评论(0编辑  收藏  举报