杭电ACM-1.2.7 GPA

GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2472 Accepted Submission(s): 1018
 

Problem Description

Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

 

Input

The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

 

Output

Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.

 

Sample Input

A B C D F

B F F C C A

D C E F

 

Sample Output

2.00

1.83

Unknown letter grade in input

 

 

代码:

#include<iostream>
#include<iomanip>
#include<string>
using namespace std;

int main()
{
     string str;
     while(getline(cin,str))
     {
          int i;
          float sum=0.0,j=0.0;
          bool flag=0;
          if(str.length())
          {
               for(i=0;i<str.length();i++)
               {
                    if(str[i]!=' ')
                    {    
                         switch(str[i])
                         {
                              case 'A':sum+=4;break;
                              case 'B':sum+=3;break;
                              case 'C':sum+=2;break;
                              case 'D':sum+=1;break;
                              case 'F':sum+=0;break;
                              default: flag=1;break;    
                         }
                         j++;
                    }
               }
               if(flag==1)
                    cout<<"Unknown letter grade in input"<<endl;
               else
                    cout<<setiosflags(ios::fixed)<<setprecision(2)
                              <<sum/j<<endl;
          }
     }
     return 0;
}

 

posted @ 2013-06-12 20:02  cityflickr  阅读(737)  评论(0编辑  收藏  举报