Find The Multiple

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100

111111111111111111


#include<cstdio>
#include<iostream>
#include<algorithm>

using namespace std;
bool f;
void dfs(__int64 x,int n,int k)
{
    if(f||k==19) return;
    if(x%n==0)
    {
        f=true;
        printf("%I64d\n",x);
        return;
    }
    dfs(x*10,n,k+1);
    dfs(x*10+1,n,k+1);
}
int main()
{
    int n;
    while(cin >> n)
    {
        f=false;
        if(n==0) return 0;
        dfs(1,n,0);
    }
    return 0;
}


posted @ 2016-02-22 21:01  一根咸鱼干  阅读(78)  评论(0编辑  收藏  举报