1128. N Queens Puzzle (20)

1128. N Queens Puzzle (20)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1, Q2, ..., QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

 
Figure 1
 
Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K <= 200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4 <= N <= 1000 and it is guaranteed that 1 <= Qi <= N for all i=1, ..., N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print "YES" in a line; or "NO" if not.

Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES


题意:判断八皇后——给出皇后的位置,判断皇后相互之间是否交叉。PS:皇后可以 上下左右 和 斜上下左右 任意走。

思路:判断横坐标相差N个单位的两个皇后,纵坐标是否也相差N个单位,是则为NO。 

           另外还要判断皇后是否在一条直线上   _(:з」∠)_开始做的时候忘了这茬,bug半天看不出来

代码:

#include<iostream>
#include<string>
using namespace std;
int check(int n)
{
	int num[1010];
	for (int i = 0; i < n; i++)
		cin >> num[i];
	for (int i = 0; i < n; i++)
		for (int j = i + 1; j < n; j++)
			if (abs(num[i] - num[j]) == abs(i - j) || num[i] == num[j]) return 0;
	return 1;
}
int main()
{
	int k, n;
	cin >> k;
	while (k--)
	{
		cin >> n;
		if (check(n)) cout << "YES" << endl;
		else cout << "NO" << endl;
	}
}





posted @ 2017-11-15 17:45  九大于七  阅读(133)  评论(0编辑  收藏  举报