1124. Raffle for Weibo Followers (20)

1124. Raffle for Weibo Followers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going...
题意:制作一个简单的微博抽奖系统。输入m人,起始中奖人是s号(从1 开始计数),下一个中奖人为s+n号,直到s+n>m

思路:思路很简单上面已经说了。我选择vector<string>存储,用字符数组也没问题。但是,用vector<string>有一个特别坑的地方,它的 num.size(),返回的不是int,而是无符号整数(unsigned int),所以不能直接和int做 > < 比较。

代码:

#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
{
	int m, n, s, i, j;
	cin >> m >> n >> s;
	vector<string> people;
	vector<string> winner;
	string tmp;
	for (int i = 0; i < m; i++)
	{
		cin >> tmp;
		people.push_back(tmp);
	}
	s--;//模拟从1开始计数
	if (s >= m) {
		cout << "Keep going..." << endl;
		return 0;
	}
	else {
		while (s < m)
		{
			int size = winner.size();//将unsigned int 转化为 int
			for (i = 0; i < size; i++)
				if (winner[i] == people[s]) break;
			if (i != size) 	s++;
			else {
				cout << people[s] << endl;
				winner.push_back(people[s]);
				s += n;
			}
		}
	}
	return 0;
}



posted @ 2017-12-04 14:51  九大于七  阅读(115)  评论(0编辑  收藏  举报