Ubuntu 20.0.4(戴尔R620)和锐捷RG-6120交换机进行端口聚合bond操作
1、交换机配置文件仔细看红色部分
telecom-yn-SWG-core-01#sh running-config
Building configuration...
Current configuration: 3475 bytes
version S6120_RGOS 12.1(2)B0102
hostname telecom-yn-SWG-core-01
!
ip access-list standard 50
!
username admin privilege 15 password admin
!
poe uninterruptible-power
!
no cwmp
!
service dhcp
!
ip dhcp pool vlan14
network 172.19.144.0 255.255.255.0
dns-server 223.5.5.5
default-router 172.19.144.11
!
install 0 RG-S6120-20XS4VS2QXS
!
sysmac 8005.88d7.7a78
!
enable service web-server http
enable service web-server https
webmaster level 0 username admin password 7 06073a0e261b
!
nfpp
!
no service password-encryption
!
redundancy
!
enable password admin
enable service ssh-server
!
vlan 14
name manager_vlan
!
vlan range 1-13,15-205
!
interface TenGigabitEthernet 0/1
port-group 1 mode active
!
interface TenGigabitEthernet 0/2
port-group 1 mode active
!
interface TenGigabitEthernet 0/3
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/4
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/5
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/6
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/7
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/8
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/9
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/10
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/11
shutdown
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/12
port-group 11
!
interface TenGigabitEthernet 0/13
port-group 12
!
interface TenGigabitEthernet 0/14
port-group 12
!
interface TenGigabitEthernet 0/15
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/16
!
interface TenGigabitEthernet 0/17
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/18
mtu 9000
switchport mode trunk
!
interface TenGigabitEthernet 0/19
!
interface TenGigabitEthernet 0/20
mtu 9000
!
interface TFGigabitEthernet 0/21
mtu 9000
!
interface TFGigabitEthernet 0/22
mtu 9000
!
interface TFGigabitEthernet 0/23
mtu 9000
!
interface TFGigabitEthernet 0/24
mtu 9000
!
interface FortyGigabitEthernet 0/25
!
interface FortyGigabitEthernet 0/26
mtu 9000
switchport mode trunk
!
interface AggregatePort 1
switchport mode trunk
!
interface AggregatePort 11
mtu 9000
switchport mode trunk
!
interface AggregatePort 12
switchport mode trunk
!
interface VLAN 1
ip address 192.168.8.208 255.255.255.0
!
interface VLAN 11
ip address 172.19.141.254 255.255.255.0
!
interface VLAN 12
ip address 172.19.142.254 255.255.255.0
!
interface VLAN 13
ip address 172.19.143.254 255.255.255.0
!
interface VLAN 14
ip address 172.19.144.11 255.255.255.0
!
interface VLAN 15
!
interface VLAN 27
ip address 172.19.140.2 255.255.255.0
!
interface VLAN 101
ip address 172.19.146.254 255.255.255.0
!
interface VLAN 102
ip address 172.19.147.254 255.255.255.0
!
interface VLAN 201
ip address 172.19.148.254 255.255.255.0
!
interface VLAN 202
ip address 172.19.149.254 255.255.255.0
!
interface Mgmt 0
ip address 192.168.1.200 255.255.255.0
!
aggregateport load-balance src-ip
!
ip route 0.0.0.0 0.0.0.0 172.19.140.1
!
snmp-server community cloudgame rw
!
line console 0
logging synchronous
privilege level 15
login local
line vty 0 4
transport input ssh
logging synchronous
privilege level 15
login local
!
end
2、Ubuntu服务器配置
network:
version: 2
renderer: networkd
ethernets:
eno1:
dhcp4: no
dhcp6: no
optional: true
eno2:
dhcp4: no
dhcp6: no
optional: true
eno3:
dhcp4: yes
dhcp6: no
optional: true
eno4:
dhcp4: no
dhcp6: no
optional: true
vlans:
vlan101:
accept-ra: no
id: 101
link: bond0
vlan102:
accept-ra: no
id: 102
link: bond0
vlan201:
accept-ra: no
id: 201
link: bond0
#addresses: [172.19.148.99/24]
#gateway4: 172.19.148.254
vlan202:
accept-ra: no
id: 202
link: bond0
bridges:
br0:
interfaces: [vlan101]
dhcp4: no
addresses: [172.19.146.99/24]
#gateway4: 172.19.148.254
parameters:
stp: false
forward-delay: 0
br1:
interfaces: [vlan201]
dhcp4: no
addresses: [172.19.148.99/24]
#gateway4: 172.19.148.254
nameservers:
addresses: [223.6.6.6,223.5.5.5]
parameters:
stp: false
forward-delay: 0
br2:
interfaces: [vlan102]
dhcp4: no
addresses: [172.19.147.99/24]
parameters:
stp: false
forward-delay: 0
br3:
interfaces: [vlan202]
dhcp4: no
addresses: [172.19.149.99/24]
parameters:
stp: false
forward-delay: 0
bonds:
bond0:
dhcp4: no
dhcp6: no
#addresses: [172.19.148.100/24]
#gateway4: 172.19.148.254
nameservers:
addresses: [223.6.6.6,223.5.5.5]
interfaces:
- eno1
- eno2
parameters:
mode: 802.3ad
mii-monitor-interval: 100
应为2000MB/s
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 全网最简单!3分钟用满血DeepSeek R1开发一款AI智能客服,零代码轻松接入微信、公众号、小程
· .NET 10 首个预览版发布,跨平台开发与性能全面提升
· 《HelloGitHub》第 107 期
· 全程使用 AI 从 0 到 1 写了个小工具
· 从文本到图像:SSE 如何助力 AI 内容实时呈现?(Typescript篇)
2022-03-22 Kubernetes之网络策略(Network Policy)
2022-03-22 Docker系列五——Docker容器隔离原理及网络通信(重要)
2022-03-22 【Docker 基础知识】存储驱动overlay和overlay2
2022-03-22 linux 六种命名空间
2022-03-22 Linux内核网络丢包查看工具dropwatch的安装和使用
2022-03-22 mysql视图是否有主键的问题
2022-03-22 go flags学习