HDU-5074

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 931    Accepted Submission(s): 651


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a1, a2, . . . , an, is simply the sum of score(ai, ai+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

 

Output
For each test case, output the answer in one line.
 

 

Sample Input

2
5 3
83 86 77
15 93 35
86 92 49
3 3 3 1 2
10 5
36 11 68 67 29
82 30 62 23 67
35 29 2 22 58
69 67 93 56 11
42 29 73 21 19
-1 -1 5 -1 4 -1 -1 -1 4 -1

 

Sample Output
270
625
 

 

Source
 

 

/**
    题意:m种点,一个长度为n的串,若串中的数为-1  则为待定,否则为这点
            求这个串的最大价值,
    做法:dp 
            分为四种情况,如果当前点是未知
                                前一个点已知
                                前一个点未知
                          如果当前点已知
                                  前一个点已知
                                  前一个点未知
            情况很少  很容易枚举
    ============================================================
                        dp是硬伤
    ============================================================
**/
#include <iostream>
#include <algorithm>
#include <string.h>
#include <cmath>
#include <stdio.h>
#include <queue>
#define maxn 110
using namespace std;
int score[maxn][maxn];
int note[maxn];
int dp[maxn][maxn];
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, m;
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= m; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                scanf("%d", &score[i][j]);
            }
        }
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &note[i]);
        }
        memset(dp, 0, sizeof(dp));
        for(int i = 2; i <= n; i++)
        {
            if(note[i] > 0)
            {
                if(note[i - 1] > 0)
                {
                    dp[i][note[i]] = dp[i - 1][note[i - 1]] + score[note[i - 1]][note[i]];
                }
                else
                {
                    for(int j = 1; j <= m; j++)
                    {
                        dp[i][note[i]] = max(dp[i][note[i]], dp[i - 1][j] + score[j][note[i]]);
                    }
                }
            }
            else
            {
                if(note[i - 1] > 0)
                {
                    for(int j = 1; j <= m; j++)
                    {
                        dp[i][j] = max(dp[i][j], dp[i - 1][note[i - 1]] + score[note[i - 1]][j]);
                    }
                }
                else
                {
                    for(int j = 1; j <= m; j++)
                    {
                        for(int k = 1; k <= m; k++)
                        {
                            dp[i][j] = max(dp[i][j], dp[i - 1][k] + score[k][j]);
                        }
                    }
                }
            }
        }
        int  sum = -1;
        if(note[n] > 0) {
            sum = dp[n][note[n]];
        }
        else
        {
            for(int i = 1; i <= m; i++)
            {
                sum = max(sum, dp[n][i]);
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}
View Code

 

posted on 2015-08-19 02:28  `Elaine  阅读(206)  评论(0编辑  收藏  举报

导航