2019年春季学期第十二周作业.
本周作业头:##
这个作业属于哪个课程 | C语言程序设计语言Ⅱ |
---|---|
这个作业要求在哪里 | https://edu.cnblogs.com/campus/zswxy/computer-scienceclass4-2018/homework/3236 |
我在这个课程的目标 | 指针进阶 |
这个作业在那个具体方面帮助我实现目标 | 如何使用指针和结构解决问题 |
参考文献 | 互联网和c语言程序设计教材 |
基础作业
6-1 计算最长的字符串长度
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:#
6
(1)实验代码
int max_len( char *s[], int n ){
int i,t=0;
for(i=0;i<n;i++){
if(t<strlen(s[i])){
t=strlen(s[i]);
}
}
return t;
}
(2)实验思路###
(3)本次实验中遇到的问题及解决方案###
问题:段错误
解决方案:百度找到的,发现了自己计算是也有错误,仔细一看就改好了。
(4)运行结果截图
6-2 统计专业人数
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:#
3
(1)实验代码
int countcs( struct ListNode *head )
{
int t=0;
while(head!=NULL){
if(head->code[1]=='0'&&head->code[2]=='2')
t++;
head=head->next;
}
return t;
}
(2)实验思路###
(3)本次实验中遇到的问题及解决方案###
问题:部分正确
解决方法:发现是自己在结构那章没有弄懂,看了下书还有查了一下就知道了。
(4)运行结果截图###
6-3 删除单链表偶数节点
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:#
1 3 5 7
(1)实验代码
struct ListNode *createlist()
{
struct ListNode*head=NULL,*pnew,*tail;
int data;
scanf("%d",&data);
while(data!=-1){
pnew=(struct ListNode*)malloc(sizeof(struct ListNode));
pnew->data=data;
if(head==NULL){
head=pnew;
tail=pnew;
}
else{
tail->next=pnew;
}
tail=pnew;
scanf("%d",&data);
}
pnew->next=NULL;
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
struct ListNode *p,*q,*r;
while(head&&head->data%2==0){
q=head;
head=head->next;
free(q);
}
q=head;
while(q&&q->next!=NULL)
{
while(q->next&&q->next->data%2==0)
{
r=q->next;
q->next=r->next;
}
q=q->next;
}
return head;
}
(2)实验思路###
(3)本次实验中遇到的问题及解决方案###
问题:部分正确
解决方法:通过调试看看错误的地方,发现了自己在建立单链表的时候出现了错误,少了一句,加上就好了。
(4)运行结果截图###
挑战作业
不是我所能承受的,抱歉。
预习作业
学习进度
学习感悟
我发现了上课一听就会,回去一做就错,所以应该要多多加强和巩固。
结对编程##
1,结对编程的过程:这次的作业前面两题还好,第三题老师讲了之后有思路了,但是还是有点困难。
2,优点:(1)可以互相学习(2)交流(3)互相提问
3,缺点:没有缺点。