hdu 1907 && hust 1112 John

题目描述

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box. Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

输入

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

输出

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case. Constrains: 1 <= T <= 474, 1 <= N <= 47, 1 <= Ai <= 4747

样例输入

2 
3 
3 5 1 
1 
1 

样例输出

John 
Brother 
尼姆博弈,很好玩的博弈问题,我就会这种和单个的博弈问题
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int sum=0,n,t,x;
    bool k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        k=false;
        sum=0;
        for (int i=0;i<n;i++)
        {
            scanf("%d",&x);
            sum^=x;
            if (x>1) k=true;
        }
        if (!k)
        {
            if (n%2==0) printf("John\n");
            else printf("Brother\n");
        }
        else
        {
            if (sum==0) printf("Brother\n");
            else printf("John\n");
 
        }
    }
    return 0;
}

 

 

posted @ 2014-04-25 23:19  Hust_BaoJia  阅读(137)  评论(0编辑  收藏  举报
努力