hdu 1081 To The Max

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle. 
Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2 
Sample Output
15
这个题是求一个矩阵的最大子矩阵,我因为没有初始化maxx,WA了好多次,教训
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int maxx;
int num[1001];
int map[1001][1001];
int top;
void dos()
{
    int ns,i;
    ns=0;
    for(i=0;i<top;i++)
    {
        ns+=num[i];
        if(ns<0)ns=0;
        maxx=max(maxx,ns);
    }
}
int main()
{
    int i,j,n,x,k;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,0,sizeof(map));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&x);
                map[i][j]=map[i][j-1]+x;
            }
        }
        maxx=-99999999;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=i;j++)
            {
                top=0;
                for(k=1;k<=n;k++)
                {
                    num[top++]=map[k][i]-map[k][j-1];
                }
                dos();
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}

 

 

posted @ 2014-04-24 19:26  Hust_BaoJia  阅读(141)  评论(0编辑  收藏  举报
努力