HDU 1058 Humble Numbers

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 
Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
记得当时学长面试的时候就是用这个题目,当时就只有想到队列生成,没有考虑dp,现在来看这题,有收获啊
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

long long a[6000];

void get_a()
{
    int L1=1,L2=1,L3=1,L4=1;
    a[1]=1;
    for (int i=2;i<=6000;i++)
    {
        a[i]=min(a[L1]*2,min(a[L2]*3,min(a[L3]*5,a[L4]*7)));
        if (a[i]==a[L1]*2) L1++;
        if (a[i]==a[L2]*3) L2++;
        if (a[i]==a[L3]*5) L3++;
        if (a[i]==a[L4]*7) L4++;
    }
}

int main()
{
    int n;
    get_a();
    while (scanf("%d",&n)!=EOF && n)
    {
        if(n % 10 == 1 && n % 100 != 11)
              printf("The %dst humble number is %lld.\n",n ,a[n]);
          else if(n % 10 == 2 && n % 100 != 12)
              printf("The %dnd humble number is %lld.\n",n ,a[n]);
          else if(n % 10 == 3 && n % 100 != 13)
              printf("The %drd humble number is %lld.\n",n ,a[n]);
          else
              printf("The %dth humble number is %lld.\n",n ,a[n]);
    }
    return 0;
}

 

 

posted @ 2014-04-24 16:02  Hust_BaoJia  阅读(141)  评论(0编辑  收藏  举报
努力