Test for Job(POJ - 3249)

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.
The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.
In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ \(10^5\), 0 ≤ m ≤ \(10^6\)) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

avatar

这道题一开始记忆花搜索TLE,后SPFA也TLE,最后让每次进入队列的入度减一,入度为零的压入队列。

代码如下:

#include <iostream>
#include <vector>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
const int maxn=1e5+10;
const int maxm=1e6+10;
#define INF 1e11
#define LL long long
using namespace std;
int n,m,in[maxn],val[maxn],flag[maxn];
vector<int> po[maxn];
LL vis[maxn];
void init()
{
	memset(val,0,sizeof(val));
	memset(in,0,sizeof(in));
	memset(flag,0,sizeof(flag));
	flag[0]=1;
	for(int i=0;i<=maxn;i++)
		vis[i]=-INF;
	vis[0]=0;
}
void spfa()
{
	queue<int> qu;
	qu.push(0);
	int temp1,temp2;
	while(!qu.empty())
	{
		temp1=qu.front();
		qu.pop();
		for(int i=0;i<po[temp1].size();i++)
		{
			temp2=po[temp1][i];
			vis[temp2]=max(vis[temp2],vis[temp1]+val[temp2]);
			in[temp2]--;
			if(in[temp2]==0)
				qu.push(temp2);
		}
	}
	LL MAX=-INF;
	for(int i=1;i<=n;i++)
		if(po[i].size()==0)
			MAX=max(vis[i],MAX);
	cout<<MAX<<endl;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
	    init();
		for(int i=0;i<=n;i++)
			po[i].clear();
		for(int i=1;i<=n;i++)
			scanf("%d",&val[i]);
		int x,y;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			po[x].push_back(y);
			in[y]++;
		}
		for(int i=1;i<=n;i++)
			if(in[i]==0)
			{
				po[0].push_back(i);
				in[i]++;
			}
		spfa();
	}

}
posted @ 2019-03-03 23:28  见风仍是风  阅读(246)  评论(0编辑  收藏  举报