General Problem Solving Techniques [Intermediate-1]~A - Children's Game

There are lots of number games for children. These games are pretty easy to play but not so easy to make. We will discuss about an interesting game here. Each player will be given N positive integer. (S)He can make a big integer by appending those integers after one another. Such as if there are 4 integers as 123, 124, 56, 90 then the following integers can be made — 1231245690, 1241235690, 5612312490, 9012312456, 9056124123, etc. In fact 24 such integers can be made. But one thing is sure that 9056124123 is the largest possible integer which can be made.

You may think that it’s very easy to find out the answer but will it be easy for a child who has just got the idea of number?

Input

Each input starts with a positive integer N (≤ 50). In next lines there are N positive integers. Input is terminated by N = 0, which should not be processed.

Output

For each input set, you have to print the largest possible integer which can be made by appending all the N integers.

Sample Input

4

123 124 56 90

5

123 124 56 90 9

5

9 9 9 9 9

0

Sample Output

9056124123

99056124123

99999

解题思路:题目的意思是输入一组数据,然后排序,将能组成的最大的数输出。可以使用string函数,其特点是两个这样的函数相加的结果是将后面那个黏贴到前面那个的后面。

程序代码:

#include<cstdio>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
string a[100];
int cmp(string a,string b)
{
return a+b>b+a;
}
int main()
{
int N,i;
while(scanf("%d",&N)==1&&N)
{
for(i=0;i<N;i++)
cin>>a[i];
sort(a,a+N,cmp);
for(i=0;i<N;i++)
printf("%*c",i,a);
printf("\n");
}
return 0;
}

posted @ 2015-10-08 20:10  简约。  阅读(149)  评论(0编辑  收藏  举报