HDU 2577---How to Type

HDU  2577

Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input

3
Pirates
HDUacm
HDUACM

Sample Output

8
8
8

Hint

 The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8 

思路: 用dpa[]和dpb[]表示capslk键的开和关状态下的次数;

代码如下:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
char s[105];
int dpa[105],dpb[105];

int  main()
{
   int T;
   scanf("%d",&T);
   while(T--)
   {
       scanf("%s",s+1);
       dpa[0]=0;
       dpb[0]=1;
       for(int i=1;s[i];i++)
       {
           if(s[i]>'Z')
           {
               dpa[i]=min(dpa[i-1]+1,dpb[i-1]+2);
               dpb[i]=min(dpa[i-1]+2,dpb[i-1]+2);
           }
           else
           {
               dpa[i]=min(dpa[i-1]+2,dpb[i-1]+2);
               dpb[i]=min(dpa[i-1]+2,dpb[i-1]+1);
           }
       }
       int len=strlen(s+1);
       printf("%d\n",min(dpa[len],dpb[len]+1));
   }
}

 

posted @ 2016-05-28 12:19  茶飘香~  阅读(283)  评论(0编辑  收藏  举报