二维树状数组

题目网址:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=109331#problem/E

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:给一个N*N的矩阵,里面的值不是0,就是1。初始时每一个格子的值为0。
现对该矩阵有两种操作:(共T次)
1.C x1 y1 x2 y2:将左下角为(x1, y1),右上角为(x2, y2)这个范围的子矩阵里的值全部取反。
2.Q x y:查询矩阵中第i行,第j列的值。

思路:1. 根据这个题目中介绍的这个矩阵中的数的特点不是 1 就是 0,这样我们只需记录每个格子改变过几次,即可判断这个格子的数字。
2. 先考虑一维的情况:
若要修改[x,y]区间的值,其实可以先只修改 x 和 y+1 这两个点的值(将这两个点的值加1)。查询k点的值时,其修改次数即为 sum(a[1] +a[2] +… + a[k])。
3. 二维的情况:
道理同一维。要修改范围[x1, y1, x2, y2],只需修改这四个点:(x1,y1), (x1,y2+1), (x2+1,y1), (x2+1,y2+1),并把这四个点(x,y)一路上溯,修改其值。
4. 而区间求和,便可用树状数组来实现。

二维树状数组基本知识 :如下所示


#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstdio>
using namespace std;
int a[1005][1005],n;

int bit(int i)
{   ///i的末尾有k个0,即求2^k=i&(i^(i-1));
    return i&(i^(i-1));
}

void update(int i,int j)
{   ///更新a[i][j]的值,及其上方节点上的值;
    int jj;
    while(i<=n)
    {
        jj=j;
        while(jj<=n)
        {
            a[i][jj]++;
            jj=jj+bit(jj);
        }
        i=i+bit(i);
    }
}

int sum(int i,int j)
{   ///求和,求a[i][j]以前的所有子树根节点的和;
    int jj;
    int summ=0;
    while(i>0)
    {
        jj=j;
        while(jj>0)
        {
            summ+=a[i][jj];
            jj=jj-bit(jj);
        }
        i=i-bit(i);
    }
    return summ;
}
int main()
{
    int x,t,x1,y1,x2,y2;
    scanf("%d",&x);
    while(x--)
    {
        scanf("%d%d",&n,&t);
        char s[2];
        for(int i=0;i<1005;i++)
        for(int j=0;j<1005;j++)
        a[i][j]=0;
        while(t--)
      {
           scanf("%s",s);
           if(s[0]=='C')
           {
              scanf(" %d %d %d %d",&x1,&y1,&x2,&y2);
              ///容斥原理;
              update(x2+1,y2+1);
              update(x2+1,y1);
              update(x1,y2+1);
              update(x1,y1);
           }
           if(s[0]=='Q')
           {
              scanf(" %d %d",&x1,&y1);
              printf("%d\n",sum(x1,y1)&1);
              ///sum(x1,y1)即为(x1,y1)点的更新次数;
           }
      }
      puts("");
    }
    return 0;
}

 

posted @ 2016-03-17 21:47  茶飘香~  阅读(345)  评论(0编辑  收藏  举报