fibonacci封闭公式及矩阵连乘

Description

The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one. 

What is the numerical value of the nth Fibonacci number?
 

Input

For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF). 
 

Sample Input

0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output

0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

typedef struct
{
  long long m[2][2];
}mat;

mat p={0,1,1,1},I={1,0,0,1};

mat calc(mat a,mat b)
{
    int i,j,k;
    mat c;
    for(i=0;i<2;i++)
    for(j=0;j<2;j++)
    {
        c.m[i][j]=0;
       for(k=0;k<2;k++)
      {
        c.m[i][j]+=a.m[i][k]*b.m[k][j]%10000;
      }
      c.m[i][j]%=10000;
    }
    return c;
}

mat matirx(int n)
{
    mat m=p,b=I;
    while(n>=1)
    {
        if(n&1) b=calc(b,m);
        n>>=1;
        m=calc(m,m);
    }
    return b;
}

int main()
{
    int i,a[42],len;
    int n;
    double s,d;
    a[0]=0;
    a[1]=1;
    for(i=2; i<40; i++)
        a[i]=a[i-1]+a[i-2];
    while(scanf("%d",&n)!=EOF)
    {
        if(n<40)
            printf("%d\n",a[n]);
        else
        {
            s=log10(1.0/sqrt(5))+n*log10((1+sqrt(5))/2.0);//fibonacci封闭公式求前四位
            len=(int)s;
            d=s+3-len;
            printf("%d...",(int)pow(10,d));

            mat tmp;
            tmp=matirx(n);                                //矩阵连乘求后四位
            printf("%04d\n",tmp.m[0][1]);
        }
    }
    return 0;
}

 

posted @ 2015-08-16 18:13  茶飘香~  阅读(279)  评论(0编辑  收藏  举报