hdu2071

 

 

Max Num

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10292    Accepted Submission(s): 6590


Problem Description
There are some students in a class, Can you help teacher find the highest student .
 

 

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 

 

Output
For each case output the highest height, the height to two decimal plases;
 

 

Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
 

 

Sample Output
180.00 182.00
 

 

 

 

 

 

 

 

 

 

#include<stdio.h>
int main()
{
  int n,m;double max,a;
  scanf("%d",&n);
  while(n--)
  {
    scanf("%d",&m);
    max=0;
    while(m--)
    {
      scanf("%lf",&a);
      if(a>max)max=a;
    }
    printf("%.2lf\n",max);
  }
}

posted @ 2013-04-24 00:12  《 》  阅读(142)  评论(0编辑  收藏  举报