杭电acm1005

 

 

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 75241    Accepted Submission(s): 17481


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5

 

 

 

 

#include<stdio.h>
int main()
{
   long a,b,n,i,f[210];
   while(scanf("%ld%ld%ld",&a,&b,&n),a!=0||b!=0||n!=0)
   {
       f[0]=1;f[1]=1;
       for(i=2;i<200;i++)
       {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==1&&f[i-1]==1)
            {
                 break;
            }
       }
       i=i-1;
       n--;
       n=n%i;
       printf("%ld\n",f[n]);
   }
}

posted @ 2013-03-28 20:41  《 》  阅读(143)  评论(0编辑  收藏  举报