1015. Reversible Primes

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

 

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner in=new Scanner(System.in);
		int num,tmp,mun;
		int d;
		while((tmp=in.nextInt())>0){
			num=tmp;
			d=in.nextInt();
			mun=change(num,d);
			if(isprime(num)&&isprime(mun)){
				System.out.println("Yes");
			}else{
				System.out.println("No");
			}
		}

	}

	private static boolean isprime(double num) {
		if (num-2<0)return false;
		if(num==2) return true;
		for(int i=2;i<=Math.sqrt(num);i++){
			if(num%i==0){
				return false;
			}
		}
		return true;
	}

	private static int change(int num, int d) {
		int mun=0;
		while(num>=d){
			mun=mun*d+num%d;
			num=num/d;
		}
		mun=mun*d+num%d;
		return mun;
	}

}

  参考

http://blog.csdn.net/apie_czx/article/details/45538361

感觉难得是把数倒过来,还有在判断素数的时候,i<=sqrt()的等于号不能漏

posted on 2017-10-22 23:40  点灯登阁夜攻书  阅读(129)  评论(0编辑  收藏  举报

导航