习题7-6 统计大写辅音字母 (15 分)

英文辅音字母是除AEIOU以外的字母。本题要求编写程序,统计给定字符串中大写辅音字母的个数。

输入格式:

输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

输出格式:

输出在一行中给出字符串中大写辅音字母的个数。

输入样例:

HELLO World!

输出样例:

4

提交:

#include <stdio.h>
#include <string.h>

int main(){
    int i,len,count=0;
    char a[81];
    gets(a);
    len = strlen(a);
    for (i=0;i<len;i++) {
        if (a[i]>'A' && a[i] <='Z' && a[i]!='E' && a[i] != 'I' && a[i] != 'O' && a[i] !='U') count++; 
    }
    printf("%d",count);
    return 0;
}

 

posted @ 2021-08-03 21:14  白玉神驹  阅读(270)  评论(0编辑  收藏  举报