第十二周作业
这个作业属于那个课程 | c语言程序设计 |
这个作业要求在哪里 | https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/3235 |
在这个课程的目标 | 链表,指针数组 |
这个作业在那个具体方面帮助我实现目标 | 链表的使用,指针数组的概念和使用 |
参考文献 | 课本 C语言程序设计 |
6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
(1)实验代码
int max_len( char *s[], int n )
{
int i,max=0;
for(i=0;i<n;i++){
int len=strlen(s[i]);
if(len>max)
max=len;
}
return max;
}
(2)设计思路
(3)问题及解决办法
无
(4)运行结果截图
6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
输出样例:
3
(1)实验代码
int countcs( struct ListNode *head )
{
int num = 0;
struct ListNode *p=head;
while(p!=NULL)
{
if(p->code[1]=='0'&&p->code[2]=='2')
num++;
p=p->next;
}
return num;
}
(2)设计思路
(3)问题及解决办法
看了书上的概念和例题,懂得了大概思路,没有什么问题
(4)运行结果截图
6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
(1)实验代码
typedef struct ListNode *List;
struct ListNode *createlist()
{
List head=NULL, tail=NULL;
int t;
scanf("%d",&t);
while(t != -1){
List temp = (List)malloc(sizeof(struct ListNode));
temp->data = t;
temp->next = NULL;
if(tail==NULL)
head = tail = temp;
else{
tail->next = temp;
tail = temp;
}
scanf("%d",&t);
}
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
List p=head,q;
while(head && head->data%2==0){
p = head;
head = head->next;
free(p);
}
p = head;
while(p && p->next){
while(p->next && p->next->data%2==0){
q = p->next;
p->next = q->next;
}
p = p->next;
}
return head;
}
(2)设计思路
这题不是很懂,所以思路很简单,想不明白
(3)问题及解决办法
这题没有什么思路,参考了别人的方法
(4)运行结果截图
预习作业
1.所在小组想要开发的项目的名称和目标;
还在想
2.项目主体功能的描述;
还在想
3.现阶段已做的准备工作;
网上找资料,了解相关知识
4.小组成员名单和进度安排。(课程设计阶段:13-17周)
彭灿 蒋锋 侯茂成
暂无
学习进度条:
学习感悟:自己学的东西还有很多,很多东西没有弄明白,还要更加努力才行
结对编程感悟:和小伙伴讨论了前面两题,但最后一题自己弄不明白,也没有讨论出好方法。但也教会了我许多