poj-3256 Cow Picnic

The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

Input
Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2.. K+1: Line i+1 contains a single integer (1.. N) which is the number of the pasture in which cow i is grazing.
Lines K+2.. M+ K+1: Each line contains two space-separated integers, respectively A and B (both 1.. N and A != B), representing a one-way path from pasture A to pasture B.
Output
Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.
Sample Input
2 4 4
2
3
1 2
1 4
2 3
3 4
Sample Output
2
Hint
The cows can meet in pastures 3 or 4.

OJ-ID:
poj-3256

author:
Caution_X

date of submission:
20191019

tags:
dfs

description modelling:
有n个岛,岛之间有单向边,每个岛都有牛,共k头牛,问有几个岛可以使得牛能够聚会

major steps to solve it:
1.dfs得出每个岛能够使多少牛到来
2.若该岛能够使k头牛都到,则该岛满足条件

AC code:

#include<cstdio>
#include<cstring>
using namespace std;
int K,N,M;
int vis[1005],sum[1005],cow[105];
int map[1005][1005];
void dfs(int x)
{
    sum[x]++;
    vis[x]=1;
    for(int i=1;i<=N;i++) {
        if(!vis[i]&&map[x][i]) {
            dfs(i);
        }
    }
}
int main()
{
    //freopen("input.txt","r",stdin);
    memset(map,0,sizeof(map));
    scanf("%d%d%d",&K,&N,&M);
    for(int i=1;i<=K;i++) {
        int x;
        scanf("%d",&x);
        cow[i]=x;
    }
    for(int i=0;i<M;i++) {
        int a,b;
        scanf("%d%d",&a,&b);
        map[a][b]=1;
    }
    for(int i=1;i<=K;i++) {
        memset(vis,0,sizeof(vis));
        dfs(cow[i]);
    }
    int ans=0;
    for(int i=1;i<=N;i++) {
        if(sum[i]==K) ans++;
    }
    printf("%d\n",ans);
}

 

posted on 2019-10-21 21:54  Caution_X  阅读(116)  评论(0编辑  收藏  举报

导航