POJ 3132 DP+素数筛

Sum of Different Primes
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 3684   Accepted: 2252

Description

A positive integer may be expressed as a sum of different prime numbers (primes), in one way or another. Given two positive integers n and k, you should count the number of ways to express n as a sum of k different primes. Here, two ways are considered to be the same if they sum up the same set of the primes. For example, 8 can be expressed as 3 + 5 and 5 + 3 but the are not distinguished.

When n and k are 24 and 3 respectively, the answer is two because there are two sets {2, 3, 19} and {2, 5, 17} whose sums are equal to 24. There are not other sets of three primes that sum up to 24. For n = 24 and k = 2, the answer is three, because there are three sets {5, 19}, {7, 17} and {11, 13}. For n = 2 and k = 1, the answer is one, because there is only one set {2} whose sum is 2. For n = 1 and k = 1, the answer is zero. As 1 is not a prime, you shouldn’t count {1}. For n = 4 and k = 2, the answer is zero, because there are no sets of two different primes whose sums are 4.

Your job is to write a program that reports the number of such ways for the given n and k.

Input

The input is a sequence of datasets followed by a line containing two zeros separated by a space. A dataset is a line containing two positive integers n and k separated by a space. You may assume that n ≤ 1120 and k ≤ 14.

Output

The output should be composed of lines, each corresponding to an input dataset. An output line should contain one non-negative integer indicating the number of the ways for n and k specified in the corresponding dataset. You may assume that it is less than 231.

Sample Input

24 3 
24 2 
2 1 
1 1 
4 2 
18 3 
17 1 
17 3 
17 4 
100 5 
1000 10 
1120 14 
0 0

Sample Output

2 
3 
1 
0 
0 
2 
1 
0 
1 
55 
200102899 
2079324314

题意:

给出n,k问将n分解成k个素数有多少种分法。

分析:

首先使用素数筛筛选出素数。

设dp[i][j]:将j分解成i个素数的方案数,那么:dp[i][j]=dp[i-1][j-su[k]]。

for枚举所有素数

  for枚举1150->1所有的值

    for枚举方案14->1

最后读入n,k直接输出dp[k][n]即可。

AC code:

#include<cstdio>
#include<cstring>
using namespace std;
bool u[1200];
int su[1200];
int dp[15][1200];
int psu[1200];
int num;
void olas()
{
    num=1;
    memset(u,true,sizeof(u));
    for(int i=2;i<=1200;i++)
    {
        if(u[i])    su[num++]=i;
        for(int j=1;j<num;j++)
        {
            if(i*su[j]>1200)    break;    
            u[i*su[j]]=false;
            if(i%su[j]==0)    break;
        }
    }
    psu[1]=su[1];
    for(int i=2;i<num;i++)
    {
        psu[i]=psu[i-1]+su[i];
    }
}
void pre()
{
    dp[0][0]=1;
    for(int i=1;i<num;i++)
    {
        for(int j=1120;j>=0;j--)
        {
            if(j>=su[i])
            {
                for(int k=14;k>=1;k--)
                {
                    dp[k][j]+=dp[k-1][j-su[i]];
                }
            }
            else break;
        }
    }
}
int main()
{
    int n,k;
    olas();
    pre();
    freopen("input.txt","r",stdin);
    while(~scanf("%d%d",&n,&k)&&n&&k)
    {
        printf("%d\n",dp[k][n]);
    }
    return 0;
}
View Code

 

posted on 2019-08-29 20:46  Caution_X  阅读(157)  评论(0编辑  收藏  举报

导航