N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

虽然floyd 的时间复杂度很高 但是可以拓展出其他应用

floyd的实质其实是一个状态转移方程

该题运用floyd求最短路的特性 将所有的各个点的关系推测出来 十分巧妙

floyd外层循环一定要先枚举中间点

#include<cstdio>
#include<algorithm>
#include<queue>
#include<string>
#include<iostream>
#include<list>
#include<stack>
#include<deque>
#include<cstring>
#include<cmath>
using namespace std;
int dis[105][105];
int mp[105][105];
int main()
{
    memset(mp,0,sizeof(mp));
    int n,m;
    int temp1,temp2;
    scanf("%d%d",&n,&m);
    for(int i=1; i<=m; i++)
    {
        scanf("%d%d",&temp1,&temp2);
        mp[temp1][temp2]=1;
        mp[temp2][temp1]=-1;
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dis[i][j]=mp[i][j];
        }
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {                
            for(int j=1;j<=n;j++)
            {
                if(dis[i][j]) continue;
                if(dis[i][k]==dis[k][j]) dis[i][j]=dis[i][k];
            }
        }
    }
    int cnt=0;
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        cnt=0;
        for(int j=1;j<=n;j++)
        {
            if(dis[i][j]&&i!=j) cnt++;
        }
        if(cnt==n-1) ans++;
    }
    printf("%d\n",ans);
    return 0;
}