HDU 2680

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7400    Accepted Submission(s): 2426


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

 

Sample Output
1 -1
 
看了别人发现,用个虚拟起点可以计算多个起点到终点的最短距离。
 
 
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <map>
#include <vector>
using namespace std;
const int N = 1005;
const int inf = 0X7000000;
int n,m,s,p,q,t,w;
int d[N][N],fa[N],dist[N],ans;
int ww[N];
void init(){
    for(int i = 0; i <= n; i++){
        for(int j = 0; j <= n; j++)
            d[i][j] = inf;
        fa[i] = i; dist[i] = inf;
    }
}
int find(int x){
    if(x == fa[x]) return x;
    return fa[x] = find(fa[x]);
}
void Union(int x, int y){
    x = find(x);
    y = find(y);
    if(x!=y) fa[y] = x;
}
void dij(int start){
    for(int i = 0; i <= n; i++){
        dist[i] = d[start][i];
    }
    dist[start] = 0;
    for(int i = 1; i <= n; i++){
        int mn = inf;
        int pos = start;
        for(int j = 1; j <=n; j++){
            if(fa[j] != start && dist[j] < mn){
                pos = j;
                mn = dist[j];
            }
        }
        Union(start,pos);
        for(int j = 1; j <= n; j++){
            if(fa[j] != start && (dist[pos]+d[pos][j]) < dist[j])
                dist[j] = dist[pos]+d[pos][j];
        }
    }
    ans = dist[s];
}
int main(){
    while(~scanf("%d %d %d",&n, &m,&s)){
        ans = inf;
        init();
        while(m--){
            scanf("%d %d %d",&p, &q, &t);
            if(t < d[p][q]) d[p][q] = t; //好像巴士不是双向的。。
        }
        scanf("%d",&w);
        for(int i = 0; i < w; i++){
            scanf("%d", &m);
            d[0][m] = 0;
        }
        dij(0);
        if(ans == inf) ans = -1;
        printf("%d\n", ans);
    }
    return 0;
}

  

posted @ 2014-11-01 15:31  canond  阅读(164)  评论(0编辑  收藏  举报