HDU 1142

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5891    Accepted Submission(s): 2168


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

 

Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

 

Sample Output
2 4
 

 

Source
 

 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1217 1385 1162 2544 2066 
 
迪杰斯特拉+记忆化搜索
 
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define N 1059
const int inf = 9999999;
int n,m,a,b,c;
int dist[N],vis[N],mp[N][N];
int dep[N];
void init()
{
    memset(vis,0,sizeof(vis));
    memset(dep,0,sizeof(dep));
    for(int i = 1; i <= n; i++)
        dist[i] = inf;
    for(int i = 1; i <= n; i++)
    for(int j = 1; j<= n; j++){
        mp[i][j] = inf;
    }
}
void dij()
{
    for(int i = 1; i <= n; i++)
        dist[i] = mp[2][i];
    vis[2] = 1;
    dist[2] = 0;
    for(int i = 2; i <= n; i++)
    {
        int min = inf;
        int pos = 1;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && dist[j] < min)
            {
                pos = j;
                min = dist[j];
            }
        }
        vis[pos] = 1;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && mp[pos][j] < inf)
            {
                int newd = dist[pos] + mp[pos][j];
                if(newd < dist[j]) dist[j] = newd;
            }
        }
    }
}

int dfs(int x)
{
    if(dep[x]) return dep[x];
    if(x == 2) return 1;
    for(int i = 1; i <= n; i++)
    {
        if(mp[x][i] < inf)
        {
            if(dist[i] < dist[x])
            {
                dep[x] += dfs(i);
            }
        }
    }
    return dep[x];
}

int main(){
    while(scanf("%d", &n),n)
    {
        scanf("%d", &m);
        init();
        while(m--)
        {
            scanf("%d %d %d", &a, &b, &c);
            mp[a][b] = mp[b][a] = c;
        }
        dij();
        printf("%d\n", dfs(1));
    }
    return 0;
}

  

posted @ 2014-10-30 09:51  canond  阅读(113)  评论(0编辑  收藏  举报