洛谷 P1596 [USACO10OCT]湖计数Lake Counting

题目描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John's field, determine how many ponds he has.

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个NxM(1<=N<=100;1<=M<=100)网格图表示。每个网格中有水('W') 或是旱地('.')。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入输出格式

输入格式:

 

Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

第1行:两个空格隔开的整数:N 和 M 第2行到第N+1行:每行M个字符,每个字符是'W'或'.',它们表示网格图中的一排。字符之间没有空格。

 

输出格式:

 

Line 1: The number of ponds in Farmer John's field.

一行:水坑的数量

 

输入输出样例

输入样例#1: 复制
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
输出样例#1: 复制
3

说明

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

思路:模拟

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,ans;
char s[110];
int map[110][110];
int dx[8]={1,-1,0,0,1,-1,-1,1};
int dy[8]={0,0,1,-1,1,1,-1,-1};
void dfs(int x,int y){
    for(int i=0;i<8;i++){
        int cx=dx[i]+x;
        int cy=dy[i]+y;
        if(cx>=1&&cx<=n&&cy>=1&&cy<=m&&map[cx][cy]){
            map[cx][cy]=0;
            dfs(cx,cy);
        }
    }
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){
        scanf("%s",s);
        for(int j=0;j<m;j++)
            if(s[j]=='W')    map[i][j+1]=1;
    }
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            if(map[i][j]){
                dfs(i,j);
                ans++;
            }
    cout<<ans;    
}

 

posted @ 2017-11-23 21:28  一蓑烟雨任生平  阅读(213)  评论(0编辑  收藏  举报