proj1088

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 69608   Accepted: 25669

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source

#include<iostream>

using namespace std;


int longest_route(int i,int j, int m, int n, int *a, int *b){
	int max_this = 1;
	if(b[i*n + j] == 0){
		if((i - 1 >= 0)&& (a[i*n + j] > a[(i - 1)*n + j])){
			max_this = longest_route(i - 1,j , m, n, a, b) + 1;
		}
		if(((j -1) >= 0)&& (a[i*n + j] > a[i*n + j - 1])){
			int temp = longest_route(i,j - 1 , m, n, a, b) + 1;
			max_this = max_this >= temp?max_this:temp;
		}
		if(((i +1) < m)&& (a[i*n + j] > a[(i + 1)*n + j])){
			int temp = longest_route(i + 1,j , m, n, a, b) + 1;
			max_this = max_this >= temp?max_this:temp;
		}
		if(((j + 1) >= 0)&& (a[i*n + j] > a[i*n + j + 1])){
			int temp = longest_route(i,j + 1 , m, n, a, b) + 1;
			max_this = max_this >= temp?max_this:temp;
		}
	}else{
		max_this = b[i*n + j];
	}
	b[i*n + j] = max_this;
	return max_this;
}



int main()
{
	int m,n;
	cin>>m>>n;
	int *a = new int[m*n];
	int *b = new int[m*n];
	for(int i = 0; i < m*n; ++i){
			b[i] = 0;
	}
	for(int i = 0; i < m*n; ++i){
			cin>>a[i];
	}
	int max = 0;
	for(int i = 0; i < m; ++i){
		for(int j = 0; j < n; ++j){
			int temp;
			if(b[i*n + j] == 0){
				temp = longest_route(i,j, m, n, a, b);
			}else{
				temp = b[i*n + j];
			}
			max = max >= temp?max:temp;
		}
	}
	cout<<max;
	return 0;
}

posted on 2013-11-02 12:42  程序猿猿猿  阅读(219)  评论(0编辑  收藏  举报

导航