HDU-4300 Clairewd’s message

      http://acm.hdu.edu.cn/showproblem.php?pid=4300

很难懂题意....

              Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2839    Accepted Submission(s): 1096

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table. Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages. But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you. Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 
Input
The first line contains only one integer T, which is the number of test cases. Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data: T<= 100 ; n<= 100000;
 
Output
For each test case, output one line contains the shorest possible complete text.
 
Sample Input
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 
Sample Output
abcdabcd qwertabcde
 
Author
BUPT
 一个wa的代码,但测试数据都过了。。。。。。。
#include<stdio.h>
#include<string.h>
int next[50005];
char s[50005],t[50005];
void getnext()
{
    int i=0,j=-1;
    next[0]=-1;
    int len=strlen(s);
    while(i<len)
    {
        if(s[i]==s[j]||j==-1)
        {
            i++;
            j++;
            next[i]=j;
        }
        else
          j=next[j];
    }
}
int kmp()
{
    int i=0,j=0;
    int lens=strlen(s);
    int lent=strlen(t);
    while(i<lent&&j<lens)
    {
        if(s[j]==t[i]||j==-1)
        {
            i++;
            j++;
            if(i==lent)
                return j;
        }
        else
            j=next[j];
    }
    return 0;
}
int main()
{
    int n,i,flag,j;
    char str[30],s1[30];
    scanf("%d",&n);
    while(n--)
    {
      scanf("%s",str);
      scanf("%s",s1);
      int len=strlen(s1);
       strcpy(t,s1+(len+1)/2);
       printf("%s",s1);
      for(i = 0; s1[i]; i++)  
        {  
            for( j = 0; j<26; j++)  
            {  
                if(s1[i] == str[j])  
                {  
                    s[i] = 'a'+j;  
                    break;  
                }  
            }  
        }  
      getnext();
    flag=kmp();
    for(i=flag;i<len-flag;i++)
        printf("%c",s[i]);
    printf("\n");
    }
    return 0;
}

ac。。。。。。。。

 #include <stdio.h>  
#include <string.h>  
int next[100005];  
char str[27];  
char s1[100005],s2[100005];  
  
void getnext(char *t)  
{  
    int i = 0,j = -1;  
    next[0] = -1;  
    while(t[i])  
    {  
        if(j == -1 || t[i] == t[j])  
        {  
            i++;  
            j++;  
            next[i] = j;  
        }  
        else  
            j = next[j];  
    }  
}  
  
int kmp(char *s,char *t)  
{  
    int i = 0,j = 0;  
    int slen =strlen(s),tlen = strlen(t);  
    getnext(t);  
    while(i<slen && j<tlen)  
    {  
        if(j == -1 || s[i] == t[j])  
        {  
            i++;  
            j++;  
            if(i == slen)  
                return j;  
        }  
        else  
            j = next[j];  
    }  
    return 0;  
}  
  
int main()  
{  
    int t,i,flag,j;  
   scanf("%d",&t);
    while(t--)  
    {  
        scanf("%s",str);  
        scanf("%s",s1);  
        int len = strlen(s1);  
        strcpy(s2,s1+(len+1)/2);  
          printf("%s",s1); 
        for(i = 0; s1[i]; i++)  
        {  
            for( j = 0; j<26; j++)  
            {  
                if(s1[i] == str[j])  
                {  
                    s1[i] = 'a'+j;  
                    break;  
                }  
            }  
        }  
        
        flag = kmp(s2,s1); 
     //    puts(s2);puts(s1);
    //    printf("%d",flag);
       for( i = flag; i<len-flag; i++)  
        {  
            printf("%c",s1[i]);  
        }  
     printf("\n");
    }  
  
    return 0;  
}  

 

posted @ 2013-10-16 16:48  疯狂的癫子  阅读(185)  评论(0编辑  收藏  举报