PAT 甲级 1077 Kuchiguse (20 分)(简单,找最大相同后缀)

1077 Kuchiguse (20 分)
 

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

 

题意:

题意是寻找一组字符串中最大相同后缀,并输出。如果没有:则输出‘nai’

题解:

简单题,可以reverse反转一下找最大前缀

AC代码:

 

#include<bits/stdc++.h>
using namespace std;
string a[105];
int main(){
    int n;
    cin>>n;
    getchar();
    for(int i=1;i<=n;i++){
        getline(cin,a[i]);
        reverse(a[i].begin(),a[i].end());
        //cout<<a[i]<<endl;
    }
    string s="";
    int f=1; 
    char c;
    for(int i=0;i<280;i++){
        for(int j=1;j<=n;j++){
            if(i>=a[j].length()){
                f=0;
                break;
            }
            if(j>=2){
                if(a[j][i]!=a[1][i]){
                    f=0;
                    break;
                }
            }else{
                c=a[1][i];
            }
        }
        if(f==1){
            s+=c;
        }
    }
    reverse(s.begin(),s.end());
    if(s!="") cout<<s;
    else cout<<"nai";
    return 0;
} 

 

 

 

posted on 2019-12-04 15:08  蔡军帅  阅读(219)  评论(0编辑  收藏  举报