PAT 甲级 1047 Student List for Course (25 分)(cout超时,string scanf printf注意点,字符串哈希反哈希)

1047 Student List for Course (25 分)
 

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of students, and K (≤), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

 

 

题意:

建立一个课程->学生的表即可。由于课程编号是从1-K,所以可以直接用vector当表。

题解:

用string型的vector数组记录每个课程中的学生名字,输出前对其排序。要注意用cout的话最后一个点会超时。

string scanf()

s.resize(10); //需要预先分配空间
scanf("%s", &s[0]);

string printf()

string s;
s="fdasf";
printf("%s\n",s.c_str());

 

AC代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<string>
#include<cstring>
using namespace std;
vector<string>v[2505];
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    for(int i=1;i<=k;i++) v[i].clear();
    for(int i=1;i<=n;i++)
    {
        string s;
        /*s.resize(10); //需要预先分配空间
        scanf("%s", &s[0]);*/
        cin>>s;
        int m;
        scanf("%d",&m);
        for(int j=1;j<=m;j++){
            int x;
            scanf("%d",&x);
            v[x].push_back(s);
        }        
    }
    for(int i=1;i<=k;i++){
        printf("%d %d\n",i,v[i].size());
        sort(v[i].begin(),v[i].end());
        for(int j=0;j<v[i].size();j++){
            printf("%s\n",v[i].at(j).c_str());
        }
    }
    return 0;
}

 

字符串哈希和反哈希:

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<string>
#include<cstring>
using namespace std;
vector<int>v[2505];
char s[10];
int getID(char name[]){
    int id=0;
    for(int i=0;i<3;i++){
        id=id*26+(name[i]-'A');
    }
    id=id*10+name[3]-'0';
    return id;
}
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    for(int i=1;i<=k;i++) v[i].clear();
    for(int i=1;i<=n;i++)
    {
        scanf("%s",&s);
        int m;
        scanf("%d",&m);
        for(int j=1;j<=m;j++){
            int x;
            scanf("%d",&x);
            v[x].push_back(getID(s));
        }        
    }
    for(int i=1;i<=k;i++){
        printf("%d %d\n",i,v[i].size());
        sort(v[i].begin(),v[i].end());
        for(int j=0;j<v[i].size();j++){
            int x=v[i].at(j);
            string s="";
            char c=x%10+'0';
            s=s+c;
            x=x/10;
            for(int kk=1;kk<=3;kk++){
                c=x%26+'A';
                s=c+s;
                x=x/26;
            }
            printf("%s\n",s.c_str());
        }
    }
    return 0;
}

 

posted on 2019-09-05 15:00  蔡军帅  阅读(216)  评论(0编辑  收藏  举报