Oulipo POJ - 3461

题目链接:https://vjudge.net/problem/POJ-3461

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
题目大意:输出a串在b串中出现的次数。
思路:Hash板子题 当然kmp也可以做 在这里为了存Hash板子 所以只放Hash的写法
看代码:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
using namespace std;
typedef long long LL;
typedef unsigned long long ull;
const int maxn=1e6+5;
const int maxm=100000+10;
const ull base=2333;
char a[maxn],b[maxn];
ull sum[maxn];
ull has,pw;
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        int ans=0;
        has=0;pw=1;
        scanf("%s%s",a+1,b+1);
        int lena=strlen(a+1);//!!!注意 这里一定是a+1而不是a
        int lenb=strlen(b+1);
//        cout<<lena<<" "<<lenb<<endl;
        for(int i=1;i<=lena;i++)//算出a的hash值
        {
            pw*=base;
            has=has*base+a[i];
        }
        for(int i=1;i<=lenb;i++)//算出b的前缀Hash值
        {
            sum[i]=sum[i-1]*base+b[i];
        }
        for(int i=lena;i<=lenb;i++)
        {
            if(sum[i]-sum[i-lena]*pw==has) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
/**

*/

 

posted @ 2019-11-25 16:22  执||念  阅读(142)  评论(0编辑  收藏  举报